[libvirt] F10 rpm problems

Daniel Veillard veillard at redhat.com
Mon Dec 8 10:39:14 UTC 2008

On Fri, Dec 05, 2008 at 03:24:31PM -0500, Ben Guthro wrote:
> So...I decided to make the leap, and upgraded to F10 (from F9)
> After my upgrade, I decided to build the libvirt rpm from source, and install it.
> So far, so good...everything built, and installs nicely.
> However, when I run virsh, I get the following error:
> virsh: error while loading shared libraries: libgnutls.so.13: cannot open shared object file: No such file or directory
> Fedora 10 has /usr/lib/libgnutls.so.26, so I'm not real sure why it is looking for the old F9 versions.
> I have tried a make clean, make distclean, even re-cloning the repo...without effect.
> Does anyone have any thoughts as to why it is choosing this version of gnutls?

  You don't have an one laying around in /usr/local which would be
picked up by the linker, but not caught by ldconfig ?


Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel at veillard.com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/

More information about the libvir-list mailing list