[libvirt] F10 rpm problems

Ben Guthro bguthro at virtualiron.com
Mon Dec 8 12:53:10 UTC 2008

I do have older versions (for chroot purposes) mounted in non-standard paths...
I don't know why it would pick it up in /data:

$ locate libgnutls.so.13

The strange part is, that it looks like it is linking against both versions:

$ ldd .libs/virsh
	linux-vdso.so.1 =>  (0x00007fff633ff000)
	libvirt.so.0 => /usr/lib/libvirt.so.0 (0x000000382da00000)
	libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x0000003cf2a00000)
	libselinux.so.1 => /lib64/libselinux.so.1 (0x0000003ce9200000)
	libgnutls.so.26 => /usr/lib64/libgnutls.so.26 (0x0000003cff600000)
	libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x0000003cf9600000)
	libxenstore.so.3.0 => /usr/lib64/libxenstore.so.3.0 (0x0000000000110000)
	libreadline.so.5 => /lib64/libreadline.so.5 (0x0000003ce7200000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003ce8a00000)
	libc.so.6 => /lib64/libc.so.6 (0x0000003ce7e00000)
	libgnutls.so.13 => not found
	libhal.so.1 => /usr/lib64/libhal.so.1 (0x0000003cf6000000)
	libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x000000000061e000)
	libdl.so.2 => /lib64/libdl.so.2 (0x0000003ce8600000)
	libz.so.1 => /lib64/libz.so.1 (0x0000003ce8e00000)
	libm.so.6 => /lib64/libm.so.6 (0x0000003ce8200000)
	/lib64/ld-linux-x86-64.so.2 (0x0000003ce6a00000)
	libtasn1.so.3 => /usr/lib64/libtasn1.so.3 (0x0000003cfee00000)
	libgcrypt.so.11 => /lib64/libgcrypt.so.11 (0x0000003cfb600000)
	libgpg-error.so.0 => /lib64/libgpg-error.so.0 (0x0000003cf8e00000)
	libresolv.so.2 => /lib64/libresolv.so.2 (0x0000003cefa00000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x0000003cf7c00000)
	libtinfo.so.5 => /lib64/libtinfo.so.5 (0x0000003cf6c00000)
	libcap.so.2 => /lib64/libcap.so.2 (0x0000003ce6e00000)

I take it that this situation is unique to my setup, and not F10?

-----Original Message-----
From: Daniel Veillard [mailto:veillard at redhat.com]
Sent: Mon 12/8/2008 5:39 AM
To: Ben Guthro
Cc: libvir-list
Subject: Re: [libvirt] F10 rpm problems
On Fri, Dec 05, 2008 at 03:24:31PM -0500, Ben Guthro wrote:
> So...I decided to make the leap, and upgraded to F10 (from F9)
> After my upgrade, I decided to build the libvirt rpm from source, and install it.
> So far, so good...everything built, and installs nicely.
> However, when I run virsh, I get the following error:
> virsh: error while loading shared libraries: libgnutls.so.13: cannot open shared object file: No such file or directory
> Fedora 10 has /usr/lib/libgnutls.so.26, so I'm not real sure why it is looking for the old F9 versions.
> I have tried a make clean, make distclean, even re-cloning the repo...without effect.
> Does anyone have any thoughts as to why it is choosing this version of gnutls?

  You don't have an one laying around in /usr/local which would be
picked up by the linker, but not caught by ldconfig ?


Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel at veillard.com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20081208/7add83b5/attachment-0001.htm>

More information about the libvir-list mailing list