[libvirt] default storage pool will not start

Albert Hopkins marduk at letterboxes.org
Sat Jul 31 12:06:57 UTC 2010

Long ago I had a VM that used a qcow image that was in the default
directory-based storage pool. Since then the VM and the image have been
deleted.  But now libvirt will not start without the image file:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/host.py", line 586, in
  File "/usr/share/virt-manager/virtManager/storagepool.py", line 67, in
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 1039, in
    if ret == -1: raise libvirtError ('virStoragePoolCreate() failed',
libvirtError: cannot open volume
'/var/lib/libvirt/images/gstable.qcow2': No such file or directory

If I simply "touch" the file, then the pool starts.  But I don't want it
around.  No other vm's reference this file.  I've tried deleting and
re-creating the pool.  I've tried removing all the files in the pool,
removing the directory, mkdir'ing the directory and then re-creating the
pool, but it still will not start without that file.  I've
grepped /etc/libvirt for the existence of that filename but it doesn't

For the life of me I can't figure out where libvirt is getting this
information from and why it thinks it needs this file.

More information about the libvir-list mailing list