[libvirt] Linker error (virStorageFileResize) while compiling latest libvirt git source

Deepak C Shetty deepakcs at linux.vnet.ibm.com
Thu Feb 2 04:30:36 UTC 2012

Thanks Laine, that worked.

On 02/02/2012 02:46 AM, Laine Stump wrote:
> On 02/01/2012 12:00 PM, Deepak C Shetty wrote:
>> On 02/01/2012 10:05 PM, Laine Stump wrote:
>>> On 02/01/2012 11:01 AM, Deepak C Shetty wrote:
>>>> Requesting zheeshan to look, as this API was added recently by him, 
>>>> as i see on the list...
>>> jdenemar just pushed a fix.
>> Do you mean the 'bogus warning about the uninit variable' fix, it 
>> does not fix the ld 'undefined reference' error
>> i just git pull'ed and did make, it still fails as below.
>>>> On 02/01/2012 08:25 PM, Deepak C Shetty wrote:
>>>>> ../src/.libs/libvirt_driver_qemu.a(libvirt_driver_qemu_la-qemu_process.o): 
>>>>> In function `qemuProcessStart':
>>>>> /home/dpkshetty/work/libvirt/libvirt/src/qemu/qemu_process.c:3343: 
>>>>> undefined reference to `virCommandAllowCap'
>>>>> ../src/.libs/libvirt_driver_storage.a(libvirt_driver_storage_la-storage_backend_fs.o): 
>>>>> In function `virStorageBackendFileSystemVolResize':
>>>>> /home/dpkshetty/work/libvirt/libvirt/src/storage/storage_backend_fs.c:1234: 
>>>>> undefined reference to `virStorageFileResize'
> Ah, I saw the warning (which ends up being an error for me) and 
> stopped looking.
> Both of those are because new patches for the first time are calling 
> functions that were previously defined, but not being called. When 
> those functions were initially created, they weren't added to 
> libvirt_private.syms, and later when they were finally used, the 
> reviewer (me) didn't think to look for the entry in 
> libvirt_private.syms because the functions already existed (and of 
> course make check worked for me because I don't build with loadable 
> modules).
> I just pushed build-breaker patches for both errors.

More information about the libvir-list mailing list