[libvirt] [PATCH v2 18/20] network: Rename @filter to @aclfilter

John Ferlan jferlan at redhat.com
Tue Aug 15 20:56:11 UTC 2017

On 08/15/2017 11:32 AM, Michal Privoznik wrote:
> On 07/26/2017 05:05 PM, John Ferlan wrote:
>> Rename the virNetworkObjListFilter to be virNetworkObjListACLFilter
>> since that's more representative of what it is. Also modify the
>> variable @filter to be @aclfilter. In the future adding the ability
>> to describe a generic @filter routine for the Export functions
>> could be a useful thing.
> Well technically this is a filter. It's only that we use ACL filter
> function for it. But the implementation is generic enough for the cb to
> be called filter IMO. Therefore I'm not a fan of this one.
> Michal

Understood - I can drop it, but then it's different than what I've
already done in nwfilter, secret, nodedevice, and storage.

"Originally" there was an ACL Filter and a "match" filter - the various
Export API's have a Match API which take 2 params (obj, flags) and
returns a bool. If there was a really common object, then that function
could be added as a filter callback function in a very generic export


More information about the libvir-list mailing list