Ceph RBD Connection

Mr. Gecko grmrgecko at gmail.com
Sat May 22 20:31:56 UTC 2021


I setup a Ceph Cluster on my system in hopes of using it with libvirtd, 
however I'm finding myself unable to have libvirtd make the connection.

[root at server ~]# virsh pool-start "${CEPH_POOL}"
error: Failed to start pool libvirt-pool
error: failed to connect to the RADOS monitor on: localhost:6789,: No 
such file or directory

I know that rbd is working as I am able to use it with the rbd utility.

[root at server ~]# rbd list libvirt-pool
[root at server ~]# rbd device map libvirt-pool/Kolab
[root at server ~]# lsblk /dev/rbd0
rbd0     253:0    0  20G  0 disk
├─rbd0p1 253:1    0   1G  0 part
└─rbd0p2 253:2    0  19G  0 part

The libvirtd logs are not providing any useful information on the issue, 
I tried changing log-level to 1 and enabling the log_filters/adding 
"1:rbd" to the log filters.

I have tried both the libvirt version 7.3.0 in my repository and the 
bleeding edge with a compile from git. Both returns the same error.

Any help in troubleshooting this issue? I'm somewhat new when it comes 
to all of this.

Thank you,

James Coleman

More information about the libvir-list mailing list