Ceph RBD Connection

Han Han hhan at redhat.com
Mon May 24 01:48:07 UTC 2021

On Sun, May 23, 2021 at 4:33 AM Mr. Gecko <grmrgecko at gmail.com> wrote:

> Hello,
> I setup a Ceph Cluster on my system in hopes of using it with libvirtd,
> however I'm finding myself unable to have libvirtd make the connection.
> [root at server ~]# virsh pool-start "${CEPH_POOL}"
> error: Failed to start pool libvirt-pool
> error: failed to connect to the RADOS monitor on: localhost:6789,: No
> such file or directory
> I know that rbd is working as I am able to use it with the rbd utility.
> [root at server ~]# rbd list libvirt-pool
> Kolab
> [root at server ~]# rbd device map libvirt-pool/Kolab
> /dev/rbd0
> [root at server ~]# lsblk /dev/rbd0
> rbd0     253:0    0  20G  0 disk
> ├─rbd0p1 253:1    0   1G  0 part
> └─rbd0p2 253:2    0  19G  0 part
> The libvirtd logs are not providing any useful information on the issue,
> I tried changing log-level to 1 and enabling the log_filters/adding
> "1:rbd" to the log filters.
> I have tried both the libvirt version 7.3.0 in my repository and the
> bleeding edge with a compile from git. Both returns the same error.
You can check the following:
1. Make sure the ceph mon node are running on the localhost:6789
2. Check if the ceph authorization is enabled on the ceph cluster. Check if
authorization is
used in rbd pool xml.
You can provide more details on the rbd pool xml, ceph conf, and the
version of librbd1(client side), ceph(server side).

> Any help in troubleshooting this issue? I'm somewhat new when it comes
> to all of this.
> Thank you,
> James Coleman
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvir-list/attachments/20210524/0db9f121/attachment-0001.htm>

More information about the libvir-list mailing list