[libvirt-users] Listing machines as non-root user

Maciej Gałkiewicz maciej.galkiewicz at gmail.com
Tue Apr 26 07:13:36 UTC 2011

I have a problem with virsh. I'm using eucalyptus software on top of xen 4
(debian squeeze). The problem is that unix user "eucalyptus" cannot see vm
machines when it executes "virsh list". My libvirt version is 0.8.8-3 from
debian sid repository. The same
problem occurs with older versions.
What is more I have tried to change unix_sock_ro_perms  to "2777". After
libvirt restart it started to work. Even when I reverted this change it was
still working. Unfortunately after server restart virsh still does not work
(I am not sure but I cannot restart my production servers right now).
Everything is fine when I run virsh as root. I have the same issue on 7

M. Galkiewicz
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20110426/15ca912c/attachment.htm>

More information about the libvirt-users mailing list