[libvirt-users] invalid argument error when using cache parameter

Igor Serebryany igor47 at moomers.org
Sat Jan 22 06:49:55 UTC 2011


	i tried to add a 'cache' argument to the 'driver' element in my
	domainxml for qemu/kvm. i tried adding cache="none" as well as
	"writethrough" and "writeback", but every time i get these errors:

libvirtError: internal error process exited while connecting to monitor: char device redirected to /dev/pts/1
qemu: could not open disk image /vms/test.img: Invalid argument 

	the full driver line looks like this:
	<driver name="qemu" type="raw" cache="none"/>

	the same domainxml works just fine without the cache parameter. does
	anyone know what i'm doing wrong? is there some other way to set the
	default cache policy on qemu/kvm? i didn't see anything in the
	config file...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20110122/5d389d64/attachment.sig>

More information about the libvirt-users mailing list