[libvirt-users] invalid argument error when using cache parameter

Igor Serebryany igor47 at moomers.org
Sat Jan 22 06:57:28 UTC 2011

Actually, I only get the error when using cache='none' -- writethrough
and writeback both work, and default works also but the cache parameter
is gone from the driver element if I do a dumpxml.

i also forgot to include versions:

cloud1:~# qemu --version
QEMU PC emulator version 0.12.5 (Debian 0.12.5+dfsg-3), Copyright (c) 2003-2008 Fabrice Bellard
cloud1:~# virsh --version


On Sat, Jan 22, 2011 at 12:49:55AM -0600, Igor Serebryany wrote:
> hi, 
> 	i tried to add a 'cache' argument to the 'driver' element in my
> 	domainxml for qemu/kvm. i tried adding cache="none" as well as
> 	"writethrough" and "writeback", but every time i get these errors:
> libvirtError: internal error process exited while connecting to monitor: char device redirected to /dev/pts/1
> qemu: could not open disk image /vms/test.img: Invalid argument 
> 	the full driver line looks like this:
> 	<driver name="qemu" type="raw" cache="none"/>
> 	the same domainxml works just fine without the cache parameter. does
> 	anyone know what i'm doing wrong? is there some other way to set the
> 	default cache policy on qemu/kvm? i didn't see anything in the
> 	config file...
> --igor

> _______________________________________________
> libvirt-users mailing list
> libvirt-users at redhat.com
> https://www.redhat.com/mailman/listinfo/libvirt-users

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20110122/9f580fce/attachment.sig>

More information about the libvirt-users mailing list