[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Shared Folders



Well, I am still with that problem, attempting to create shared folders, so I will try to be more specific and then maybe somebody can help me.

When I say "I am trying to set up shared folders", I mean that I set this configuration in my XML description:

    <filesystem type='template' accessmode='mapped'>
      <source name='/home/guilhermesgb/Desktop/SharedFolder/>
      <target dir='/home/tarciso/Desktop/SharedFolder'/>
    </filesystem>

This was my last attempt. I also tried all other combinations, with accessmodes "passthrough" and "squash", for filesystem type "mount" too.

I can't send you any error messages neither printscreens because my problem is that anything happens, the domain is started properly but no shared folder is specified so I can mount it, using command "sudo mount -t vboxsf SharedFolder /home/tarciso/Desktop/SharedFolder". I always get a protocol error.

I was expecting libvirt to automatically do this step for me, so I wouldn't need to do it manually through vbox GUI or VBoxManage.

During my searches through the web, I found this other option, although I can't be sure if it is implemented, as the libvirt website says nothing about it: defining an XML file with this configuration:

    <shareddir fstype="ext4" path="/home/guilhermesgb/Desktop/SharedFolder" mount_tag="SharingName" security_model="passthrough" />

And then mounting it with proper command (the same as before, now with the mount_tag specified: "sudo mount -t vboxsf SharingName /home/tarciso/Desktop/SharedFolder" . Unfortunatelly the same error persists.

Am I missing something?

Sorry if my first message was hard to understand. Thanks.

2011/6/1 Guilherme Santos <guisgb13 gmail com>
Good afternoon.

I am having trouble trying to set up shared folders in the guest VM using VirtualBox hypervisor. No matter what configuration is defined in my XML, it never works, I mean, no shared folder is added/specifyed, then, inside the guest, when I try to mount the folder, I always get a protocol error.

If I use VirtualBoxManage, I can add/specify shared folders easily and mount it with no problem.

I need to use libvirt in order to deal, in a generalized way, with the process of creating shared folders in all hypervisors supported by libvirt, otherwise my problem would be solved already. I must not use specific commands of a certain hypervisor (such as VirtualBoxManage's).

How does libvirt allow me to set up shared folders? Does it use VirtualBoxManage for VBox hypervisors? If so, how do I use it?
I've read the documentation and followed it in defining my XMLs.

Thanks anyway!
--
Guilherme Santos G. Baptista
Undergraduate in Computer Science at UFCG
LSD - Distributed Systems Laboratory



--
Guilherme Santos G. Baptista
Graduando em Ciência da Computação pela UFCG
LSD - Laboratório de Sistemas Distribuídos

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]