[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] Is libvirt supported on Citrix Xenserver?



Hi Maththias,

Thanks a lot for your response!.

Is there a specific version of libvirt from which xenserver support is added? I am getting the below error

"error: invalid argument in libvirt was built without the 'xenapi' driver"

I have installed libvirt from citrix yum repo.

I am using Xenserver 5.5 with libvirt 0.8.2 and it does not seem to be working.

Thanks,

Naresh

On Jun 15, 2011 7:03 PM, "Matthias Bolte" <matthias bolte googlemail com> wrote:
> 2011/6/15 G Naresh Kumar <naresh gadepalli gmail com>:
>> Hi,
>> Is libvirt supported on Citrix Xenserver. I have been searching for the same
>> with little/no luck.
>> If supported, can you point to some links/documents which can help me try
>> out the same.
>> Thanks,
>> Naresh
>
> libvirt can use XenAPI via libxenserver [1]. That should allow you to
> use libvirt with a Citrix XenServer. You can use virsh like this
> assuming you have a libxenserver enabled libvirt:
>
> virsh -c xenapi://my-xen-server
>
> But it's true, there is no documentation about this on the libvirt website yet.
>
> [1] http://community.citrix.com/display/xs/Download+SDKs
>
> --
> Matthias Bolte
> http://photron.blogspot.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]