[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] Problems running virtual machines after an upgrade



Hi all,

 I upgraded qemu-kvm and libvirt to the new versions
 qemu-kvm at : 1.0
 libvirt at          : git version 0.9.10

I lost the original machines but the xml files were are all present (it
is not showing up in virsh list --all)

But when I import an xml I get an error: Attached is some information
which might be helpful
Can someone help please ?

If this is a compatibility issue please can someone tell me which is the
latest version of qemu-kvm and libvirt combination which will work ?
I cannot use qemu plain since it does not yet support boot from scsi

thanks

-----------------------------------------------
$ sudo virsh list --all
 Id    Name                           State
----------------------------------------------------

$ lsmod | grep kvm
kvm_intel             112920  0
kvm                   280656  1 kvm_intel
             
$ /usr/local/sbin/libvirtd --version
/usr/local/sbin/libvirtd (libvirt) 0.9.10

$ ./qemu-system-x86_64 --version
QEMU emulator version 1.0-bcv (qemu-kvm-1.0), Copyright (c) 2003-2008
Fabrice Bellard
 
$ sudo virsh define ./debian.xml
error: Failed to define domain from ./debian.xml
error: unknown OS type hvm

$ cat debian.xml
<domain type='kvm'>
  <name>debian</name>
  <uuid>0aab8869-ff87-14ce-a00b-944cdca7acf7</uuid>
  <memory>524288</memory>
  <currentMemory>524288</currentMemory>
  <vcpu cpuset='6-7'>2</vcpu>
  <cputune>
    <vcpupin vcpu='0' cpuset='6'/>
    <vcpupin vcpu='1' cpuset='7'/>
  </cputune>
  <os>
    <type arch='x86_64' machine='pc-0.14'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <cpu match='exact'>
    <model>core2duo</model>
    <vendor>Intel</vendor>
    <topology sockets='1' cores='2' threads='1'/>
    <feature policy='disable' name='lahf_lm'/>
  </cpu>
  <clock offset='localtime'>
    <timer name='hpet' tickpolicy='catchup'/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/local/bin/kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/VIRT/disks/DEBIAN'/>
      <target dev='sda' bus='scsi'/>
      <address type='drive' controller='0' bus='0' unit='0'/>
    </disk>
    <disk type='block' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    </disk>
    <controller type='scsi' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04'
function='0x0'/>
    </controller>
    <controller type='ide' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01'
function='0x1'/>
    </controller>
    <interface type='bridge'>
      <mac address='52:54:00:71:62:f3'/>
      <source bridge='virt'/>
      <model type='e1000'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03'
function='0x0'/>
    </interface>
    <serial type='pty'>
      <target port='0'/>
    </serial>
    <serial type='pty'>
      <target port='0'/>
    </serial>
    <console type='pty'>
      <target type='serial' port='0'/>
    </console>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' keymap='en-gb'/>
    <sound model='ich6'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06'
function='0x0'/>
    </sound>
    <video>
      <model type='cirrus' vram='9216' heads='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02'
function='0x0'/>
    </video>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05'
function='0x0'/>
    </memballoon>
  </devices>
</domain>






-- 
Bhasker C V


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]