[libvirt-users] Issue with event registration

Tyrion Lannister tlannister12 at gmail.com
Thu Jan 5 06:02:34 UTC 2012

An update. I compiled and ran the example provided with the src code
event-test.c and this gave the same error. Interestingly, if I run the
event-test.py script (i ran once with use_pure_python_event_loop set to
true and once with false), it runs fine, both with pure and native event
loop implementations. What could be the problem?



On Wed, Jan 4, 2012 at 2:30 PM, Tyrion Lannister <tlannister12 at gmail.com>wrote:

> Hi,
> I could find only one post related to this, but that did not address my
> problem. I am trying to register for VM events using
> virConnectDomainEventRegisterAny, but that is returning with the error
> "libvir: Remote error : this function is not supported by the connection
> driver: no event support"
> I have registered for the default event implementation (as suggested in
> the response to an earlier post related to this problem) prior to calling
> *RegisterAny, but that is not helping.
> Browsing through the coe, it seems to me this has to do with the timer
> support in the domainEventState, just a guess.
>     if (priv->domainEventState->timer < 0) {
>          remoteError(VIR_ERR_NO_SUPPORT, "%s", _("no event support"));
>          goto done;
>     }
>  I am using Centos 6 with KVM QEMU.
> Thanks,
> Tyrion
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20120104/fe51c95b/attachment.htm>

More information about the libvirt-users mailing list