[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt-users] vm grub errors



Hello,
I've set up a kvm host and used virt-install to create a new guest VM
installed to logical volumes. It works great!
However all subsequent guests I attempt to create the same way refuse to
boot. They all get stuck at the grub rescue menu reporting "no such
device".

I tried installing a new guest and dropping to a shell just before
finalizing the installation so I could examine the contents of grub.cfg
To my eyes it actually looks just fine. It is referencing the correct
virtual drive. Here is a pastebin with a few commands and output I
thought might be relevant.

http://pastebin.com/GwqbY7X7

Once I finalize the installation the same thing happens. Grub reports
the same error.

At the grub rescue prompt if I attempt to:
  ls (hd0,msdos1)/
error: unknown filesystem.

In the host I can see that the logical volume where I installed
the root partition of the VM above is in fact active. This is exactly
the same way I installed the first VM on the same host and that one i
still working fine. On a local machine I practiced setting up multiple
VM's this way and had no problem so it's not an error I can reproduce
anywhere other than the production server.

Can anyone offer ideas of other things I should try or check?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]