[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt-users] pom for 0.5.1



H Doug,

I have not dived into this yet but will. For now I can say that the proxy we are using, Sonar-Nexus, gets asked for libvirt-0.5.1.pom. Looking at the local pom.xml this is the correct query. In (y)our maven repo only a pom.xml is present, so nothing gets transferred from the libvirt repo to the proxy. I think the build process should copy pom.xml to libvirt-0.5.1.xml and looking at version 0.4.9 this seems to have happened. 0.5.0 suffers the same fault.

I will look into filling a maven repo coming weeks and if no one has followed up on this thread, I will.

Regards,
Daan Hoogland

-----Original Message-----
From: cardoe cardoe com [mailto:cardoe cardoe com] On Behalf Of Doug Goldstein
Sent: donderdag 10 oktober 2013 22:45
To: Daan Hoogland
Cc: libvirt-users redhat com
Subject: Re: [libvirt-users] pom for 0.5.1

On Thu, Oct 10, 2013 at 9:10 AM, Daan Hoogland <DHoogland schubergphilis com> wrote:
> H,
>
>
>
> I am using libvirt from maven using a nexus proxy pointing to 
> http://www.libvirt.org/maven2/
>
> It downloads the jar fine but is expecting libvirt-0.5.1.pom (and 
> …sha1). In the proxy only the jar appears. When I download and rename 
> the pom to my local .m2 cache my build works fine. Is this a bug in 
> the distribution of libvirt in its maven repo or is my dependency wrong somehow?
>
>
>
> Kind regards,
>
> Daan Hoogland

Fairly sure most of the libvirt devs aren't really sure how to put together a Maven repo and rely on the community to help us out. If you have instructions on how to generate the pom correctly then we would appreciate that and could incorporate that into future releases.

--
Doug Goldstein


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]