[libvirt-users] qemu/kvm: "spurious APIC interrupt"

Stefan G. Weichinger lists at xunil.at
Wed May 20 15:54:45 UTC 2015

I know, that this might be more QEMU-specific than a libvirt-topic ...

but I hope that someone in here can point me to a solution as well as
there are many qemu-users in here as well I assume.


I run an ancient linux-VM with a 2.2.x kernel (I have to keep it up as
the software in there is compiled against that ...)

We get a lot of dmesg-lines like:

spurious APIC interrupt on CPU#0, should never happen

I think that this slows the VM down?

I tried to disable APIC in the VMs config and in the VM (kernel-option)
etc but without success so far.

I also tried various clock-settings ...

might setting another <type> in the vm.xml help?

I have:

    <type arch='x86_64' machine='pc-1.1'>hvm</type>

the original installation was on a Pentium 2 or 3, if I remember correctly.

fyi: the host is a Gentoo Linux machine, libvirt 1.2.15, qemu 2.2.1-r2

Any pointers? google didn't help much here.

Thanks, Stefan

More information about the libvirt-users mailing list