[libvirt-users] libvirt and VMWare Workstation Shared Server mode (of GSX history)

Matthias Bolte matthias.bolte at googlemail.com
Sun May 31 08:06:42 UTC 2015

2015-05-21 22:53 GMT+02:00  <vincent at cojot.name>:
> Hi everyone,
> I searched previous postings and I couldn't find a definitive answer on
> this..
> I run a small lab of RHEL/Centos Based servers on which there's VMWare
> Workstation running on a non-standard port but still manageable by tools
> like VMrun (and the Fusion of Workstation GUI, of course).
> I'm trying to use virsh with this setup and getting the following error from
> both RHEL6 and RHEL7:
> $ virsh -c esx://user1@server1:943/?no_verify=1
> Enter user1's password for server1:
> error: internal error Expecting product 'gsx' or 'esx' or 'embeddedEsx' or
> 'vpx' but found 'ws'
> error: failed to connect to the hypervisor
> I tried 'gsx' as a type too but to no avail.
> The mode that I'm using is called by vmware a 'ws-shared' mode..:
> $ /usr/bin/vmrun -T ws-shared -h https://localhost:943/sdk -u user1
> listRegisteredVM
> Host password:
> Total registered VMs: 35
> [ha-datacenter/standard] VCS41_node1/VCS4.vmx
> [ha-datacenter/standard] VCS41_node2/VCS4.vmx
> [ha-datacenter/standard] VCS41_node3/VCS4.vmx
> [ha-datacenter/standard] VCS41_node4/VCS4.vmx
> [ha-datacenter/standard] VCS51_node1/VCS5.vmx
> [ha-datacenter/standard] VCS51_node2/VCS5.vmx
> [ha-datacenter/standard] VCS51_node3/VCS5.vmx
> [ha-datacenter/standard] VCS51_node4/VCS5.vmx
> [ha-datacenter/standard] DOS622/dos.vmx
> [ha-datacenter/standard] Solaris8/solaris8.vmx
> [ha-datacenter/standard] Solaris10/solaris10.vmx
> [ha-datacenter/standard] VCS60_node1/VCS6.vmx
> [ha-datacenter/standard] VCS60_node2/VCS6.vmx
> [ha-datacenter/standard] MacOSX_107/Mac_OS_X_Lion.vmx
> [...]
> Would that be something easy to hack/add for the libvirt versions I'm using?
> (RHEL6/7) even if this means recompiling some src.rpms..
> Any suggestions?
> Thanks,

Here's a quick hack you can test. It should make the ESX driver treat
a VMware Workstation as VMware GSX server. This should work then:

virsh -c gsx://user1@server1:943/?no_verify=1

Matthias Bolte
-------------- next part --------------
A non-text attachment was scrubbed...
Name: treat-ws-as-gsx.patch
Type: application/octet-stream
Size: 632 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20150531/b9ea25bc/attachment.obj>

More information about the libvirt-users mailing list