[libvirt-users] problem with disk virtio driver

Andrea Bolognani abologna at redhat.com
Wed Oct 5 15:42:42 UTC 2016

On Wed, 2016-10-05 at 15:00 +0100, Andrei Perietanu wrote:
> Hi Andrea, 
>    Thanks for the reply; 
>    To shed some more light on the matter I performed a few
> more tests; each time doing a clean install. I installed
> ubuntu14.04 as the guest OS, keeping everything else the
> same. 
> On my custom Linux I've created ubuntu VMs before (using
> ide drivers) and it all works file. This time I created the
> VM using virtio disk drivers and the installation didn't
> even finish. It reported a disk related error saying it's
> not being able to read from /dev/vda. I restarted the
> machine...same error.

Okay, that makes more sense :)

If the OS installer can access the disk, the installed OS
should as well - or at the very least it should be possible
to configure it to do so, eg. by including the relevant
kernel modules in the initramfs.

>     Just to make sure that I have not messed anything up,
> I did the same on the ubuntu host, so installed ubuntu guest
> on an ubuntu host uding the same guest config xml. This time
> everything worked fine. So it looks like a problem with the
> kvm virtio drivers.
>     I was trying to stay away from updating the qemu package
> because adding the package takes a long time (usually,
> because of missing dependencies), but I'm not sure I have
> any other option at this point...

You should really try taking one of the Ubuntu-on-virtio
guests that you managed to create successfully on the Ubuntu
host and copying it over to the custom Linux host (guest
configuration + qcow2 disk image) to see whether it can

Failing that I guess upgrading QEMU is your best bet.

Andrea Bolognani / Red Hat / Virtualization

More information about the libvirt-users mailing list