[libvirt-users] Permission denied for volume create in raw format

Maciej Nabożny maciej.nabozny at cloudover.io
Fri Oct 7 10:02:48 UTC 2016

I'm facing similar problem to described here:
I got Libvirt pool mounted over netfs and I'm trying to create new volume,
with pool.createXML. When format is qcow2, everything works fine.
Unfortunately, for raw images libvirt raises error Permission denied. Whole
pool is owned by root. Libvirt starts as root user too.

I've tried to change pool's permissions to 777 on filesystem, but i get the
same error, only for RAW images. Volume's xml looks like:
    <capacity unit='bytes'>{{image.size}}</capacity>
        <format type='{{ image.format }}'/>

I've tried to create it without defining permissions, but it's the same.
Problem exists in Ubuntu Server 16.04 (libvirt from repo) and Raspbian
(libvirt in version 1.2.9). Do you know if it is possible solve this
problem with this version of libvirt?

Maciej Nabożny
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20161007/dacf85e2/attachment.htm>

More information about the libvirt-users mailing list