[libvirt-users] Permission denied for volume create in raw format

Martin Kletzander mkletzan at redhat.com
Fri Oct 7 13:49:42 UTC 2016

On Fri, Oct 07, 2016 at 12:02:48PM +0200, Maciej Nabożny wrote:
>I'm facing similar problem to described here:
>I got Libvirt pool mounted over netfs and I'm trying to create new volume,
>with pool.createXML. When format is qcow2, everything works fine.
>Unfortunately, for raw images libvirt raises error Permission denied. Whole
>pool is owned by root. Libvirt starts as root user too.
>I've tried to change pool's permissions to 777 on filesystem, but i get the
>same error, only for RAW images. Volume's xml looks like:
>    <name>{{user.id}}_{{image.id}}</name>
>    <source>
>    </source>
>    <capacity unit='bytes'>{{image.size}}</capacity>
>    <target>
>        <format type='{{ image.format }}'/>
>        <permissions>
>            <mode>660</mode>

So this fails even with:

    <owner>{{ user.uid }}</owner>
    <group>{{ user.gid }}</group>

added to the permissions?  If you create qcow2 image who is the owner of
that image? (user:group)

>        </permissions>
>    </target>
>I've tried to create it without defining permissions, but it's the same.
>Problem exists in Ubuntu Server 16.04 (libvirt from repo) and Raspbian
>(libvirt in version 1.2.9). Do you know if it is possible solve this
>problem with this version of libvirt?
>Maciej Nabożny

>libvirt-users mailing list
>libvirt-users at redhat.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: Digital signature
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20161007/09aef4d8/attachment.sig>

More information about the libvirt-users mailing list