[libvirt-users] Increasing video memory available to Windows

Alex mysqlstudent at gmail.com
Sat Aug 5 20:13:52 UTC 2017


On Sun, Jul 23, 2017 at 3:45 PM, Pavel Hrdina <phrdina at redhat.com> wrote:
> On Sat, Jul 22, 2017 at 03:03:06PM -0400, Alex wrote:
>> Hi,
>> I have a fedora25 system with a Windows10 host and would like to use
>> it for photoshop. However, it complains the video memory is too low.
>> I'm using the QXL driver and it appears to be limited to 256MB? I've
>> installed the Red Hat QXL driver in Windows.
> What driver did you installed?  There are two drivers, qxl and qxldod,
> for windows 10 you need the qxldod and I would give it a try to use the
> latest drivers [1], not the stable ones.
> [1] <https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/latest-virtio/>

It looks like that fixed it. I must have been using the x86 version
all along, thinking the amd64 was only for AMD chips, and I have an

I tried to change the CPU settings to those you recommended, and it
didn't like it. When I use 'virsh edit" for the host, make the cpu
changes, then try to save, I receive:

error: XML document failed to validate against schema: Unable to
validate doc against /usr/share/libvirt/schemas/domain.rng
Extra element cpu in interleave
Element domain failed to validate content

Failed. Try again? [y,n,i,f,?]:

I currently have the following CPU info:

  <vcpu placement='static'>2</vcpu>
  <cpu mode='host-model'>
    <model fallback='allow'/>

When I made the CPU changes, I kept the vcpu config and replaced the
"cpu mode..." section.

This is the real info from /proc/cpuinfo. Do you have any idea what I
might be doing wrong?

processor       : 7
vendor_id       : GenuineIntel
cpu family      : 6
model           : 60
model name      : Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
stepping        : 3
microcode       : 0x22
cpu MHz         : 3509.777
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 3
cpu cores       : 4
apicid          : 7
initial apicid  : 7
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe
syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts
rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq
dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm
pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave
avx f16c rdrand lahf_lm abm epb tpr_shadow vnmi flexpriority ept vpid
fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm
ida arat pln pts
bugs            :
bogomips        : 6803.22
clflush size    : 64
cache_alignment : 64
address sizes   : 39 bits physical, 48 bits virtual
power management:


More information about the libvirt-users mailing list