[libvirt-users] Increasing video memory available to Windows

Pavel Hrdina phrdina at redhat.com
Mon Aug 14 16:48:48 UTC 2017

On Sat, Aug 05, 2017 at 04:13:52PM -0400, Alex wrote:
> Hi,
> On Sun, Jul 23, 2017 at 3:45 PM, Pavel Hrdina <phrdina at redhat.com> wrote:
> > On Sat, Jul 22, 2017 at 03:03:06PM -0400, Alex wrote:
> >> Hi,
> >> I have a fedora25 system with a Windows10 host and would like to use
> >> it for photoshop. However, it complains the video memory is too low.
> >> I'm using the QXL driver and it appears to be limited to 256MB? I've
> >> installed the Red Hat QXL driver in Windows.
> >
> > What driver did you installed?  There are two drivers, qxl and qxldod,
> > for windows 10 you need the qxldod and I would give it a try to use the
> > latest drivers [1], not the stable ones.
> >
> > [1] <https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/latest-virtio/>
> It looks like that fixed it. I must have been using the x86 version
> all along, thinking the amd64 was only for AMD chips, and I have an
> Intel.

That's a common mistake, amd64 is an official name for that
architecture because it was AMD who introduced that architecture, but
nowadays x86_64 is used.  It's the same as i386 and x86, the original
32-bit architecture was introduced by Intel.

> I tried to change the CPU settings to those you recommended, and it
> didn't like it. When I use 'virsh edit" for the host, make the cpu
> changes, then try to save, I receive:
> error: XML document failed to validate against schema: Unable to
> validate doc against /usr/share/libvirt/schemas/domain.rng
> Extra element cpu in interleave
> Element domain failed to validate content
> Failed. Try again? [y,n,i,f,?]:

Oh, right, that was my fault, I didn't realize that you probably have
older version of libvirt, try to use this configuration:

  <cpu mode='host-passthrough'>
    <topology sockets='1' cores='2' threads='1'/>

There is no "check" attribute for "cpu" element in older libvirts.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20170814/65e80ff4/attachment.sig>

More information about the libvirt-users mailing list