[libvirt-users] virsh confirmed edits do not persist

Josh Mcneil josh at mcneilio.com
Thu Feb 21 06:06:48 UTC 2019

This may be user error, I am new to libvirt.

I am using libvirt 5.0.0. I have created a VM (win10) in the system URI
using virt-manager. I stopped the VM to edit it.

I set my LIBVIRT_DEFAULT_URI="qemu:///system" and am able to read the
domain configuration with `EDITOR=nano virsh edit win10`. When I save
(ctrl+o) and exit (ctrl+x) I see the message "Domain win10 XML
configuration edited." as expected. However, when I run the edit command
again the changes do not appear to have persisted.

I have tried starting and stopping the VM. I read that I may need to define
the domain with virsh so I did that. None of these things seem to work.

I would appreciate it if someone could help me solve this issue in order to
be able to modify domains from virsh!

Thanks in advance for any help!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20190221/1fbc8df0/attachment.htm>

More information about the libvirt-users mailing list