[libvirt-users] virsh confirmed edits do not persist

Ján Tomko jtomko at redhat.com
Thu Feb 21 07:16:13 UTC 2019

On Thu, Feb 21, 2019 at 01:06:48AM -0500, Josh Mcneil wrote:
>This may be user error, I am new to libvirt.


>I am using libvirt 5.0.0. I have created a VM (win10) in the system URI
>using virt-manager. I stopped the VM to edit it.
>I set my LIBVIRT_DEFAULT_URI="qemu:///system" and am able to read the
>domain configuration with `EDITOR=nano virsh edit win10`. When I save
>(ctrl+o) and exit (ctrl+x) I see the message "Domain win10 XML
>configuration edited." as expected.

that means libvirt successfully parsed the changed XML file.
The elements libvirt does not parse will not appear in the changed
configuration. Usually those should get caught by the schema validation,
but it's not perfect.

What were the exact changes you were trying to make?

>However, when I run the edit command
>again the changes do not appear to have persisted.
>I have tried starting and stopping the VM. I read that I may need to define
>the domain with virsh so I did that. None of these things seem to work.

Calling 'virsh define' with the same domain name and UUID in the XML and
'virsh edit' is equivalent - both call virDomainDefineXMLFlags under the


>I would appreciate it if someone could help me solve this issue in order to
>be able to modify domains from virsh!
>Thanks in advance for any help!

>libvirt-users mailing list
>libvirt-users at redhat.com

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/libvirt-users/attachments/20190221/b62a5d84/attachment.sig>

More information about the libvirt-users mailing list