[libvirt-users] stuck in pxe loop from uefi + tianocore/ovmf

jsl6uy js16uy js16uy at gmail.com
Thu Jan 24 16:23:03 UTC 2019

Any thoughts all?
Just a final check-in. I have had help before and it is/was appreciated!
Probably not explaining effectively or too corner case
regards all

On Fri, Jan 18, 2019 at 12:56 PM jsl6uy js16uy <js16uy at gmail.com> wrote:
> Hello all, hope all is well
> Was wondering if I'm doing something wrong/missing something.
> I have pxe+tftp+uefi working between 2 vms. However after the build is
> done and I reboot, I still come up to pxe b/c tianocore always starts,
> from what I've seen, with trying PXE first. Great for initial builds
> :) but I would like to it stop after.
> In the xml I am pointing to the disk to boot first. if I virsh destory
> and run qemu directly on the qcow image, the vm comes up as expected
> and boots into the OS
> I have tried removing the nvram under
> /var/lib/libvirt/qemu/nvram/virtmachine. But the vm boots up and
> starts looking for pxe again.
> If I let that timeout, then type exit and select continue in the
> tianocore boot firmware, I just loop back into trying pxe over ipv4
> etc
> I tried <rom bar='off'/> on the e1000 and that does work to stop pxe.
> Then I get to the uefi shell quickly, but all I see at that point is 2
> BLK maps pointing to floppy 1 and 2. I see nothing when I try to
> manually add a new boot option.
> any help/wisdom would be appreciated.
> libvirtd (libvirt) 4.9.0
> qemu command:
> sudo qemu-system-x86_64 -m 2048 -L /usr/share/ovmf/x64/ -bios
> OVMF_CODE.fd -drive
> file=/images/rdhcli02,format=qcow2,cache=writeback,if=virtio -device
> virtio-net,netdev=net10,mac=52:54:00:11:22:33 -netdev
> tap,id=net10,ifname=rdhcli02,script=no,downscript=no
> Is there a way to address this?

More information about the libvirt-users mailing list