[Linux-cluster] build errors on the latest cvs

Daniel McNeil daniel at osdl.org
Sat Jan 29 00:51:46 UTC 2005

I trying to re-build after update from cvs .

Using 'make' gets:

ln -snf libmagmamsg.so.DEVEL.1106957305 libmagmamsg.so.DEVEL
ln -snf libmagma.so.DEVEL.1106957305 libmagma.so
ln -snf libmagma_nt.so.DEVEL.1106957305 libmagma_nt.so
ln -snf libmagmamsg.so.DEVEL.1106957305 libmagmamsg.so
install -d /Views/redhat-cluster/cluster/build/lib
install -d /usr/lib
install: cannot change permissions of `/usr/lib': Operation not permitted
make[2]: *** [install] Error 1
make[2]: Leaving directory `/Views/redhat-cluster/cluster/magma/lib'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/Views/redhat-cluster/cluster/magma'

so it looks like slibdir is not being set right.

I tried building from a clean view and got the same error. :(

Running 'make install' as root does work with (with my patch
to add -pthread to the ccs_tool Makefile), but I like
building it all first before installing it.


More information about the Linux-cluster mailing list