[Linux-cluster] build errors on the latest cvs

Rick Stevens rstevens at vitalstream.com
Sat Jan 29 01:08:51 UTC 2005

Daniel McNeil wrote:
> I trying to re-build after update from cvs .
> Using 'make' gets:
> ln -snf libmagmamsg.so.DEVEL.1106957305 libmagmamsg.so.DEVEL
> ln -snf libmagma.so.DEVEL.1106957305 libmagma.so
> ln -snf libmagma_nt.so.DEVEL.1106957305 libmagma_nt.so
> ln -snf libmagmamsg.so.DEVEL.1106957305 libmagmamsg.so
> install -d /Views/redhat-cluster/cluster/build/lib
> install -d /usr/lib
> install: cannot change permissions of `/usr/lib': Operation not permitted
> make[2]: *** [install] Error 1
> make[2]: Leaving directory `/Views/redhat-cluster/cluster/magma/lib'
> make[1]: *** [install] Error 2
> make[1]: Leaving directory `/Views/redhat-cluster/cluster/magma'
> so it looks like slibdir is not being set right.
> I tried building from a clean view and got the same error. :(
> Running 'make install' as root does work with (with my patch
> to add -pthread to the ccs_tool Makefile), but I like
> building it all first before installing it.

Of COURSE you can't change the permissions of /usr/lib as a normal,
mortal user.../usr/lib is owner: root, group: root.  That's why installs
HAVE to be done by root.  Mere mortals aren't allowed to screw with
important things like /usr/lib or /lib.
- Rick Stevens, Senior Systems Engineer     rstevens at vitalstream.com -
- VitalStream, Inc.                       http://www.vitalstream.com -
-                                                                    -
-            I'm afraid my karma just ran over your dogma            -

More information about the Linux-cluster mailing list