[Linux-cluster] build errors on the latest cvs

Daniel McNeil daniel at osdl.org
Sat Jan 29 01:35:11 UTC 2005

On Fri, 2005-01-28 at 17:08, Rick Stevens wrote:
> Daniel McNeil wrote:
> > I trying to re-build after update from cvs .
> > 
> > Using 'make' gets:
> > 
> > ln -snf libmagmamsg.so.DEVEL.1106957305 libmagmamsg.so.DEVEL
> > ln -snf libmagma.so.DEVEL.1106957305 libmagma.so
> > ln -snf libmagma_nt.so.DEVEL.1106957305 libmagma_nt.so
> > ln -snf libmagmamsg.so.DEVEL.1106957305 libmagmamsg.so
> > install -d /Views/redhat-cluster/cluster/build/lib
> > install -d /usr/lib
> > install: cannot change permissions of `/usr/lib': Operation not permitted
> > make[2]: *** [install] Error 1
> > make[2]: Leaving directory `/Views/redhat-cluster/cluster/magma/lib'
> > make[1]: *** [install] Error 2
> > make[1]: Leaving directory `/Views/redhat-cluster/cluster/magma'
> > 
> > so it looks like slibdir is not being set right.
> > 
> > I tried building from a clean view and got the same error. :(
> > 
> > Running 'make install' as root does work with (with my patch
> > to add -pthread to the ccs_tool Makefile), but I like
> > building it all first before installing it.
> Of COURSE you can't change the permissions of /usr/lib as a normal,
> mortal user.../usr/lib is owner: root, group: root.  That's why installs
> HAVE to be done by root.  Mere mortals aren't allowed to screw with
> important things like /usr/lib or /lib.

I should have been more clear: when doing a "make"
it should not be touching anything like /usr/lib/ or /lib.
It is ok if 'make install' puts stuff in /usr/lib or /lib
and other places (and that part must be done as root).

It looks like the Makefile uses a prefix to a local directory.
'slibdir' is not using "/Views/redhat-cluster/cluster/build"
prefix that 'libdir' above did (see the install -d line above
the one that failed), so it does not build without being root.
That is the build problem.  Mere mortals should be able to build :)


More information about the Linux-cluster mailing list