[Linux-cluster] Kernel panic: GFS: Assertion failed on line 550 of file rgrp.c

Kevin Anderson kanderso at redhat.com
Fri Feb 10 16:38:23 UTC 2006

On Fri, 2006-02-10 at 22:59 +0700, Thai Duong wrote:
> Hi Kevin,
> I did unmount oracle_u02 before cloning but still no luck. 
> When I tried to run gfs_fsck against oracle_u02 on the backup
> cluster's node, it reported something like below:
> [root at rac3 root]# gfs_fsck -y /dev/pool/oracle_u02
> Initializing fsck
> Buffer #65773 (1 of 5) is neither GFS_METATYPE_RB nor GFS_METATYPE_RG.

Add some -vvvvvvv flags to the gfs_fsck command line. Each "v" adds
another layer of messages.  The DEBUG messages are at layer 7. This
should print out more information about the resource group that it is
failing to read.

> Resource group is corrupted.
> Unable to read in rgrp descriptor.
> Unable to fill in resource group information.
> It seems that oracle_u02 somehow got broken. Running gfs_fsck against
> oracle_u01 works like a charm. Do i need to run gfs_fsck against the
> original oracle_u02? Please advise.

It would be interesting to see if the partitions are identical after the
snapshot.  How large are the LUNs?  Can you do a comparison of the
volumes?  I would do those steps first before the fsck.  It is possible
you have a problem with the oracle_u02, so would be interesting to run
gfs_fsck if the snapped LUNs are identical.


More information about the Linux-cluster mailing list