[Linux-cluster] field displayed in "cman_tool services" command

Siman Hew simanhew at yahoo.com
Mon Feb 19 19:26:30 UTC 2007

Thanks David & Robert.

Actually the real problem I have is that I can not
stop "active subsystems", so I use this command to
check what services are running.
For example, first of all, I run cman_tool status:
node04:/etc/init.d# cman_tool status
Protocol version: 5.0.1
Config version: 8
Cluster name: cluster01
Cluster ID: 730
Cluster Member: Yes
Membership state: Cluster-Member
Nodes: 3
Expected_votes: 4
Total_votes: 3
Quorum: 3
Active subsystems: 2
Node name: node04
Node ID: 1
Node addresses:

In which it tells us 2 active subsystems:
hostname:/etc/init.d# cman_tool services
Service          Name                              GID
LID State     Code
Fence Domain:    "default"                           5
  2 join      S-6,20,1

User:            "usrm::manager"                     3
  3 join      S-8,40,2
[2 1]

Using clustat -x to confirm:
node04:/etc/init.d# clustat -x
Timed out waiting for a response from Resource Group
<?xml version="1.0"?>
<clustat version="4.1.1">
  <quorum quorate="1" groupmember="1"/>
    <node name="node03" state="1" local="0"
estranged="0" rgmanager="1"
    <node name="node01" state="1" local="0"
estranged="0" rgmanager="0"
    <node name="node02" state="0" local="0"
estranged="0" rgmanager="0"
    <node name="node04" state="1" local="1"
estranged="0" rgmanager="1"

Check rgmanager status:
node04:/etc/init.d# rgmanager status
clurgmgrd (pid 4755 4754) is running...

Then try to stop it:
node04:/etc/init.d# rgmanager stop
Shutting down cluster Servie Manager...
Waiting for service to stop:

but looks it is waiting for the service to stop

I tried to stop fenced.
node04:/etc/init.d#./fenced status
fenced (pid 3913) is running...

node04:/etc/init.d#./fenced stop
Stopping fence domain:     [ OK ]

node04:/etc/init.d#./fenced status
fenced (pid 3913) is running...

Seems fenced did not stop fenced properly, although it
told us [ OK ].

Any sequence I did is wrong? Just got confused ?

Any hint is very appreciated.

--- David Teigland <teigland at redhat.com> wrote:

> On Mon, Feb 19, 2007 at 06:49:05AM -0800, Siman Hew
> wrote:
> > Hello,
> > 
> > When I try to check the services in a cluster, I
> am
> > using "cman_tool services", what I get is
> something
> > like this:
> ......
> Now, on to your specific problem.  By the looks of
> it I'd say that your
> machine is trying to fence someone. 
> /var/log/messages will usually have
> some clear information about what's wrong.  Source
> code debugging using
> the info above is probably the wrong place to start.
> Dave

Do you Yahoo!?
Everyone is raving about the all-new Yahoo! Mail beta.

More information about the Linux-cluster mailing list