[Linux-cluster] Error with gfs_grow/ gfs_fsck

Miolinux miolinux at libero.it
Tue Jun 3 13:53:34 UTC 2008


I tried to expand my gfs filesystem from 250Gb to 350Gb.
I run gfs_grow without any error or warnings.
But something gone wrong.

Now, i cannot mount the gfs filesystem anymore (lock computer)

When i try to do a gfs_fsck i get:

[root at west ~]# gfs_fsck -v /dev/mapper/VolGroup_FS100-LogVol_FS100 
Initializing fsck
Initializing lists...
Initializing special inodes...
Validating Resource Group index.
Level 1 check.
371 resource groups found.
Setting block ranges...
This file system is too big for this computer to handle.
Last fs block = 0x1049c5c47, but sizeof(unsigned long) is 4 bytes.
Unable to determine the boundaries of the file system.
Freeing buffers.

Like when trying to access a >16Tb on 32bit.
But the disk below is just 350Gb!!

[root at west ~]# lvdisplay /dev/mapper/VolGroup_FS100-LogVol_FS100 
  --- Logical volume ---
  LV Name                /dev/VolGroup_FS100/LogVol_FS100
  VG Name                VolGroup_FS100
  LV UUID                6kPwvg-AOuA-iUOY-KboE-PyRO-DPNt-5yeD3h
  LV Write Access        read/write
  LV Status              available
  # open                 0
  LV Size                349.99 GB
  Current LE             89597
  Segments               3
  Allocation             inherit
  Read ahead sectors     0
  Block device           253:17

How can i resolve the issue? / How can i recover the data?


CentOS 5.1
[root at west ~]#  rpm -qa|grep -i gfs
[root at west ~]# uname -a
Linux west.polito.it 2.6.18-53.1.21.el5PAE #1 SMP Tue May 20 10:03:06
EDT 2008 i686 i686 i386 GNU/Linux

P.s: tried also gfs-utils-0.1.17-1 gfs_fsck but with no luck :(

More information about the Linux-cluster mailing list