[Linux-cluster] Error with gfs_grow/ gfs_fsck

Bob Peterson rpeterso at redhat.com
Tue Jun 3 17:23:00 UTC 2008


On Tue, 2008-06-03 at 15:53 +0200, Miolinux wrote:
> Hi,
> I tried to expand my gfs filesystem from 250Gb to 350Gb.
> I run gfs_grow without any error or warnings.
> But something gone wrong.
> Now, i cannot mount the gfs filesystem anymore (lock computer)
> When i try to do a gfs_fsck i get:
> [root at west ~]# gfs_fsck -v /dev/mapper/VolGroup_FS100-LogVol_FS100 
> Initializing fsck
> Initializing lists...
> Initializing special inodes...
> Validating Resource Group index.
> Level 1 check.
> 371 resource groups found.
> (passed)
> Setting block ranges...
> This file system is too big for this computer to handle.
> Last fs block = 0x1049c5c47, but sizeof(unsigned long) is 4 bytes.
> Unable to determine the boundaries of the file system.

You've probably hit the gfs_grow bug described in bz #434962 (436383)
and the gfs_fsck bug described in 440897 (440896).  My apologies if
you can't read them; permissions to individual bugzilla records are
out of my control.

The fixes are available in the recently released RHEL5.2, although
I don't know when they'll hit Centos.  The fixes are also available
in the latest cluster git tree if you want to compile/install them
from source code yourself.  Documentation for doing this can
be found at: http://sources.redhat.com/cluster/wiki/ClusterGit


Bob Peterson
Red Hat Clustering & GFS

More information about the Linux-cluster mailing list