[Linux-cluster] Problem with shared storage and volume groups

michael.osullivan at auckland.ac.nz michael.osullivan at auckland.ac.nz
Tue Sep 16 20:51:28 UTC 2008

Hi everyone,

I have a shared storage device that my 2-node cluster can see
(/dev/storage on both nodes). I wanted to set up a GFS system on the
shared storage, but I am having problems getting both nodes to recognise a
clustered volume group. To set up the clustered volume group I have used
one of the cluster nodes (let's call it node 1).

First, I created a physical volume on my storage device

pvcreate /dev/storage

Then I created a clustered volume group

vgcreate -c y storage_vg /dev/storage

However, when I run

vgchange -aly

on the other cluster node (node 2) I get an error stating that node 2
can't find a volume group with the correct UUID. If I run vgscan and then
vgchange -aly the error goes away, but node 2 still can't see storage_vg.

I have also tried using conga without any success.

Can anyone help? Please let me know if you need more info.

Thanks, Mike

More information about the Linux-cluster mailing list