[Linux-cluster] Named pipes not working on GFS2 in Redhat 5.x,

Pietrzak, Piotr (CMS rtBSS) piotr.pietrzak at hp.com
Wed Aug 1 10:37:15 UTC 2012

Hello Bob,

                The problem has been reported by one of my customer, but I was not able to set up a real cluster so I have built a cluster with single machine, all software cluster and GFS2 installed and set up just one node. It allows me to mount GFS2 filesystem and conduct tests with application and shell steps.

In the real system following piece of code crashed application start up

if ( ioctl( nFifoDescr, FIONREAD, &lSize) == -1 ) {
        errNo = errno;

However when I have built the test system I was able to see that when I have created pipes on the GFS2 and I tried to use in shell I am getting an error message.

For instance when I tried to write to pipe following error shows up immediately

[root at erm4 gfs_test]# echo test > msg_act_0.pipe
-bash: echo: write error: Invalid argument

When I try to read from pipe following error comes

[root at erm4 gfs_test]# cat <msg_mon_0.pipe
cat: -: Invalid argument

I considered this as a good test, at least it shows that there is a problem with pipes.

The situation remain the same with two kernels I have tried 5.5 and 5.8.

Regards support I am trying to find OEM agreement to raise a request towards RedHat support, but as the problem has been identified some time ago and it seems that solution was released I wonder maybe I should just install something like GFS2 new kernel module or anything else, that's the reason I dropped this thread.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-cluster/attachments/20120801/d44303ad/attachment.htm>

More information about the Linux-cluster mailing list