[Linux-cluster] Problems building fence-agents from source

Alan Evangelista alanoe at linux.vnet.ibm.com
Thu Oct 23 13:49:45 UTC 2014


I'm trying to build fence-agents from source (master branch) on CentOS 6.5.
I already installed the following rpm packages (dependencies): autoconf,
automake, gcc, libtool, nss, nss-devel. When I tried to run ./autogen.sh,
I got:

configure.ac:162: error: possibly undefined macro: AC_PYTHON_MODULE
       If this token and others are legitimate, please use m4_pattern_allow.
       See the Autoconf documentation.

I then run

$ autoreconf --install

and autogen worked. Then, I have a problem running ./configure:

./configure: line 18284: syntax error near unexpected token `suds,'
./configure: line 18284: `AC_PYTHON_MODULE(suds, 1)'

I never had this problem before with earlier fence-agents versions.
Am I missing something or is there an issue with upstream code?

RPM dependencies versions:

Alan Evangelista

More information about the Linux-cluster mailing list