[linux-lvm] SuSE/LVM boot problem

Marco Shaw marco at nbnet.nb.ca
Wed May 3 00:15:58 UTC 2000

On Tue, 2 May 2000 dgould at suse.com wrote:

Well I just have the eval version so no 2nd CD.  I tried creating a lilo
disk with another system, but I guess lilo needs the same
boot.b/system.map files to create a lilo disk?

So now I'm left with creating lilo on a disk somehow with another
system...  How could I create it?  Otherwise, I could always install a
copy of SuSE 6.3 in a VMWare VM and create a disk there...


> On Tue, May 02, 2000 at 11:51:31AM +0000, Michael Marxmeier wrote:
> > > 
> > > I lost my floppy with lilo on it.  Now I have to reconstruct it.  I've
> > > tried booting in rescue mode, but even the rescue SuSE CD doesn't appear to
> > > have LVM support.
> > > 
> > > What can I do at this point?
> > 
> > Use the installation disk - it has LVM support while the Rescue disk has not.
> > You can boot from the 2nd CD-ROM into the old Yast, do a "expert install"
> > and switch to a shell.
> > 
> Be careful. I have found that the install disks are very happy to create
> systems that cannot be booted because lilo does not know about lvm.
> On this topic, what is needed to make lvm work for both / and /boot with
> full lilo support? I think it somewhat limits the utility of lvm not to
> be able to make a fully lvm system, and might be tempted to do some of
> the heavy lifting if it is not too gruesome.
> -dg

More information about the linux-lvm mailing list