[linux-lvm] lvm_chr_ioctl / unable to activate vg

Conny Brunnkvist / dimac.net c.brunnkvist at speednames.com
Tue Jun 26 07:55:10 UTC 2001

Hello everyone. After searching around a bit in the list-archives, I still
can't figure out exactly how to advance.. This is my problem: 
I was running kernel 2.4.3 (stock) and LVM tools some-earlier-version than
0.9.1_beta6.. I recently switched to kernel 2.4.4 because I heard that it
contained lots of LVM and ReiserFS(my FS of choice) related fixes. 
In the same swing, I also installed the LVM tools from the latest packages
for slackware, 0.9.1_beta6.

After rebooting into 2.4.4, the volume group wouldn't activate, so I
switched back to 2.4.3 but now it didn't work there either! Got exactly the
same error message: 

# vgchange -v -ay
vgchange -- locking logical volume manager
vgchange -- finding all volume group(s)
vgchange -- checking volume group name "vg0"
vgchange -- checking existence of volume group "vg0"
vgchange -- reading volume group data for "vg0" from lvmtab
vgchange -- checking volume group consistency of "vg0"
vgchange -- checking if all physical volumes of volume group "vg0" are
vgchange -- creating VGDA for "vg0" in kernel
lvm -- lvm_chr_ioctl: unknown command 4004fe0a
vgchange -- ERROR "Invalid argument" activating volume group "vg0"

vgchange -- unlocking logical volume manager

So, I speculate it has to do with the change of userland tools versions...
Too bad I just can't remember which version I ran before the reboot... 

Any help on what I should do to get it up and running again would be
appreciated. I really don't want to loose any data! :-F


More information about the linux-lvm mailing list