[linux-lvm] Removing PV with disk errors from VG

James Hawtin oolon at ankh.org
Mon Mar 11 10:26:03 UTC 2002

On Mon, 11 Mar 2002, Heinz J . Mauelshagen wrote:

> well that's a bug in 1.0.3 which will be fixed in 1.0.4.
> If you wnat to try it at your own risk, check out LVM1 CVS and
> try "pvmove -i" again.
> 1.0.4 will hopefully be released this week :)
> Regards,
> Heinz    -- The LVM Guy --

Hmmm, I had a problem with pv move over the weekend as well.. I was
replacing a hard disk for more space. and when I tried pvmove it worked
for 2 small partitions, but for a larger data area it failed to move
(because of a read error). Interestingly I had not got any error messages
in dmsg about bad seeks.

Not knowing about pvmove -i I feel back to my old system for using tar in
a pipe to move data, not quick not pretty but it works ;-)

So fortunately it looks like it was a virgin sector.

My question is.... This pvmove bug does it make "read error" problems in
which  case the disk might be ok, or does it just not handle read errors

Yes I was using 1.0.3.

The Disk was an 46G IBM (From the ICL (newer glass platter C**p)) so I am
willing to beleive it was a disk problem (I have space on the shelf so
it can sit with its friends) it which case I will not use the disk agian.

I already lost 2 IBM disks from the older range and have another one
which when I have the money I will be swapping out... Agh! I hate IBM. Yup
i know I can RMA it, but whats the point if the new one might have
problems too, my data is worth more than that.

Does make for fun at computer fairs though,

Me:   I need a new harddisk...
Them: IBM make the best ones.
(The specs are great and are dead fast)
Me:   IBM disks live fast and die fast, what do you have in a non IBM

PS anyone else know of other brands I should avoid buying?


More information about the linux-lvm mailing list