[linux-lvm] VGs not detected at startup

David S. dgs at gs.washington.edu
Mon Nov 8 09:40:08 UTC 2004

> I'm running lvm2.00.25 on kernel 2.6.9, but I have problems with
> detecting the VGs.Immediately after bootup, vgscan returns: no volume
> groups found, same for lvscan and pvscan. I have my root
> partition on my Primary IDE-Drive (hda) and the VGs lie on the
> serial-ATA-Drive (sda).
> Now after I run fdisk on /dev/sda (just run it an quit again). all my
> VGs mysteriously appear on the next vgscan.
> I guess I'm missing something, but I can't see what. Does anyone know
> this problem?

Yes, I certainly know this problem.  I'm running LVM2 2.00.15 and device
mapper 1.00.17 on a 2.6.9 (x86) kernel.  'Vgscan' fails to find an vloumes
running from the system initialization script, but works fine a few seconds
(I'm guessing) later run from 'rc.local'.  I've tried a few things to "fix"
this, all to no effect.

David S.

> Thanks in advance
> markus
> -- 
> Mit freundlichen Gr?ssen
> Markus Wiedmer - FHBB

> _______________________________________________
> linux-lvm mailing list
> linux-lvm at redhat.com
> https://www.redhat.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/

More information about the linux-lvm mailing list