[linux-lvm] Trouble with XFS/Snapshot

Bruno Bonfils bonfils at fimasys.fr
Wed Jan 12 13:23:15 UTC 2005


I'm trying to use the snapshot feature, but i have trouble. I don't
have error message (kernel or others), i don't know how to check if
lvcreate still running..

My first try was with a volume group of ~ 580 GB (hardware raid 5)
I created a logical volume 50GB, create a XFS Filesystem, put some
data (~1GB) and run the following commands :

$ xfs_freeze -f <mount point>
$ lvcreate -v -s -L 2GB -n snapshot <device>

I have high load average, small io (~ 170 blk_wrtn/s), but nothings
happens after more than hour, lvcreate is still running, i can't kill
him, i can't do a software reboot, etc..

My second try has the same config, except i tried to set the -c
argument to 6 (which correspond to the chunk_size of the raid 5, 64K) if i
understand correctly how to use this options, same result than the first.

My third and last try was with a simple volume of 60 GB, a logicial
volume of 1G, !50M of data put in the fs, and the command :

$ xfs_freeze -f <mount point> 
$ lvcreate -v -s -L 500M -n <name> <device>

And still the same problem. I hard reboot the computer after one hour
lvcreate running.. I don't think the system need more 1h to copy 500M

So my question, are there some know wells trouble about the snapshot
features ? Do you think that work better with LVM 1 ? How can i check
the state/progress of lvcreate ?

Thanks for your help.

-- here my hard/software configuration --

SCSI AACRAID Controler with a lot of disk (11 x 68GB)
Linux Kernel 2.6.10 with dm-snapshot, dm-mirror, etc.. (running debian sarge)
XFS (xfsprogs version 2.6.20)
LVM 2.00.24-1 (Debian Sarge Version)

(sorry if you have received two times this mail, may have trouble with gmane)

Bruno Bonfils

More information about the linux-lvm mailing list