[linux-lvm] Can't mount logical volume - super block error

Scott Serr serrs at theserrs.net
Thu Mar 3 08:05:29 UTC 2005

Sasha Z wrote:

>I had a functioning lvm using four hard discs, but found it necessary
>to rebuild my operating system. Since then, while the vg and lv come
>online are read available, I can't actually mount the filesystem or do
>anything with it. It says it cannot read the superblock at locations 2
>and 16.
>does anybody have any thoughts on this?
I'm not sure what you mean by "the vg and lv come online are read 
available..."  Have you tried:
pvdisplay [-v]
lvdisplay [-v]

All looks good? 

Are you sure you have your file system turned on in your kernel?  How 
about explicitly mounting it with "-t"?

I probably can't help other than have you describe more for the gurus.

>I've tried 2.00.25 and 2.00.33.
I just went from kernel 2.4.27 with lvm 2.00.25 to 2.6.10 with 2.00.33, 
it worked ok for me, just to give you a data point.

More information about the linux-lvm mailing list