[linux-lvm] Can't mount logical volume - super block error

Brian McCullough bdmc at bdmcc-us.com
Tue Mar 15 16:56:44 UTC 2005

On Thu, Mar 03, 2005 at 01:05:29AM -0700, Scott Serr wrote:
> Sasha Z wrote:
> >I had a functioning lvm using four hard discs, but found it necessary
> >to rebuild my operating system. Since then, while the vg and lv come
> >online are read available, I can't actually mount the filesystem or do
> >anything with it. It says it cannot read the superblock at locations 2
> >and 16.
> >
> I'm not sure what you mean by "the vg and lv come online are read 
> available..."  Have you tried:
> pvscan
> pvdisplay [-v]
> lvdisplay [-v]
> All looks good? 

I have a very similar problem, and discovered this message.

As recommended, I have run all three commands above, and everything
looks normal.  I will give output in a subsequent message.

Leading up to this:

Over the past week, I have been completely rebuilding this system,
replacing the main ( root ) disk drive, and installing a fresh distribution.
To this I want to add the old "data" disk drive, which has one PV, one
VG and four LVs on it. 

The data drive is a SATA drive, one of two mirrored on a single
controller, which were seen as hde and hdg in the old system.  Now,
aside from issues which appear to prevent the second channel of the
Silicon Image 3112 card from being used with "modern" kernels ( tried
2.4.27, 2.6.8 and 2.6.10 ), the drive seems to be recognized as "sda".

OK, so I changed my /etc/raidtab to have the new drive name, and it
appears to start up correctly.  I am also able to run vgscan, vgchange,
pvscan, pvdisplay and lvdisplay, and all results appear "normal."

However, as the previous writer described, mount refuses to work with
these Logical Volumes, as below:

root at tri1:/mnt# mount /dev/VGProjectData/lvol4 misc
/dev/VGProjectData/lvol4: Invalid argument
mount: /dev/VGProjectData/lvol4: can't read superblock


root at tri1:/mnt# mount -t ext3 /dev/VGProjectData/lvol4 misc
mount: wrong fs type, bad option, bad superblock on \
	or too many mounted file systems
	( could this be the IDE device where you in fact use
	ide-scsi so that sr0 or sda or so is needed? )

Any suggestions for my next step?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 2229 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20050315/a02d1f31/attachment.bin>

More information about the linux-lvm mailing list