[linux-lvm] Problem reading/writing to disk

Patrick McKinney linux-lvm at prmckinney.com
Mon Oct 17 01:16:05 UTC 2005

I'm having problems with reads and writes to my LVM disks stalling after
transferring a bit of data.

I have 2 250G SATA disks in a logical volume.  I initially only had one of
the drives in the LV with JFS, the other was stand alone with XFS.  I was
able to transfer all of the data (~90% full) off the standalone drive onto
the LV, and then I changed the partition to Linux LVM, and extended my
LG/LV to include both drives.  I remounted,resized the JFS partition, and
confirmed the additional space with df.  But now I see problems
reading/writing data.  If I try to transfer a 1Gig file from root (PATA
disk with ext3) to my LV it copies the 1st ~400M at nice fast transfer
speed, but then it seems to stall out, and xfer rate drops to ~1M/s!  I
see the same behavior if I try to copy a file from LVM to my root, except
it gets about 600M before stalling.

Any ideas what is going on here??  I've tried moving the disks to a
different computer (using a sata_piix controller vs sata_sil).  So I don't
think it is the SATA controller, and like I said the drives worked fine
independently.  So I think probably has something to do with LVM, but I'm
not sure how to go about debugging this problem (I don't see any errors in
the logs).

BTW, this is a x86 box running fedora core 4 (2.6.13-1.1526_FC4 kernel)
  LVM version:     2.01.08 (2005-03-22)
  Library version: 1.01.02 (2005-05-17)
  Driver version:  4.4.0


More information about the linux-lvm mailing list