[linux-lvm] Contents of read-only LVM snapshot change - still have the problem with latest LVM!

Roger Lucas roger at planbit.co.uk
Tue Nov 14 11:53:55 UTC 2006

> I have tried updating to the 2.02.14 LVM and the 1.02.12 device mapper (compiled from source from
> the FTP site).  The first couple
> of tests have run correctly so it looks like this may have resolved the issue, but I am continuing
> to run tests to confirm this.

It's still not working reliably.  The first few attempts worked but after running more tests, the problem still occurs. 

My test reads the read-only snapshot multiple times.  All the data is consistent across the 20GB snapshot except for a single byte
at offset 0x0313CAC6C0.  Sometimes it reads 0x48 and other times it reads 0x08.  I have run the tests multiple times over many days
and, although the tests sometimes show the correct behaviour, about half the time I get this problem.

I cannot understand why repeated reads of a read-only snapshot would return data that changes.

I am running the kernel and have upgraded to the latest LVM 2.02.14 and DMapper library 1.02.12 but the problem still

Can anyone offer any help as to what may be going on or suggest how I can investigate the problem further?  I don't mind patching
the LVM source code to obtain more debug information if this helps.

Thanks in advance,


More information about the linux-lvm mailing list