[linux-lvm] LVM problem - how to recover?

Richard Kampmann Richard.Kampmann at freenet.de
Tue Nov 28 20:15:09 UTC 2006

Hi everybody ...

I recently had a lvm crash from which I now have to recover. So now I need 
your help ...

The system is a SUSE 10.1 system with actual patches.
# uname -rio i386 GNU/Linux
# lvm version
  LVM version:     2.02.02 (2006-02-07)
  Library version: 1.02.03 (2006-02-08)
  Driver version:  4.5.0

There was the unenlightened crash and before there was a volume goup spanning 
two physical partitions (sda2, sdb2), each on one physical disk (sda, sdb).
The system froze (maybe in coincidence with some snapshot-handling) and I had 
to press the reset button. When rebooting lvm told me he could not open the 
volume group because one pv was missing. The partition looked OK when 
checking the partition table. I tried several things - and to do a 
vgcfgrestore but it did not help.

The volume group (system_vg) contained the root partition, so I installed a 
new system on a third disc and tried to recover the old volume group.
Unfortunately when doing the pvcreate for the two physical volumes I did NOT 
choose the "--zero n" switch.

Fact is: I now have the volume group containing two physical discs and two 
physical volumes with the correct PV UUIDs. But the first sectors are zeroed, 
aren't they?

Any way to recover the LVs of the old volume group? A vgcfgrestore (YES, there 
was a vgcfgbackup before!) does not work ... bad luck.

Ah - and all logical volumes contain Reiser Filesystems V 3.6 - they MUST 
still be there ...

So - what could be my next steps?


Richard Kampmann
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20061128/a69a829c/attachment.sig>

More information about the linux-lvm mailing list