[linux-lvm] LV open but not mounted ?

paddy paddy at panici.net
Tue Oct 10 10:46:54 UTC 2006

On Mon, Oct 09, 2006 at 04:49:35PM -0500, Jonathan E Brassow wrote:
> Hmmm, I can see where it might be 'active', but if it's not in use, it 
> shouldn't be open.

It is open. lvchange -an says LV in use: not removing

but I'm drawing a blank on finding anything that is actually using it.

I'm kinda hoping someone can throw some light on what 'open' is here.

> Some sub-lvs are marked as 'open', because they are used by the main LV 
> (such is the case with mirroring and snapshots).

no mirrors, no snapshots :-(

I have looked through /etc/lvm/backups and can't see anything odd.

> Have you tried 'lsof <path to LV>' ?

yup, tried lsof, tried fuser, there is no nfs, got nowhere.
It's one of those things where I fully expect to have to say "d'oh sorry!",
but until I can get deeper into it I am really stumped.

> On Oct 9, 2006, at 1:58 PM, paddy wrote:
> >
> >I just noticed that I have a system where an LV appears to be open
> >(as given by lvs), but I can't see it mounted anywhere, or opened
> >by any process.
> >
> >Any insights, suggestions, explanations, etc gratefully received :-)

Perl 6 will give you the big knob. -- Larry Wall

More information about the linux-lvm mailing list