[linux-lvm] Redirecting LVM command output on RHEL5?

Joubert, Kevin kevin.joubert at hp.com
Wed Aug 1 19:08:43 UTC 2007


Okay.. I am probably missing something simple here but...

I just added a RHEL5 system to my lab and I am testing a script that
captures LVM structure. 
This script works on other versions of RHEL and SLES, but on RHEL5,
whenever I try to redirect LVM command output, I get a blank. 

For instance...

[root at linux-dl585 ~]# pvs
  PV         VG   Fmt  Attr PSize  PFree
  /dev/sda   vg01 lvm2 a-   10.00G    0
  /dev/sdd   vg02 lvm2 ax    1.95G 1.08G
  /dev/sde   vg02 lvm2 ax    1.95G 1.46G

[root at linux-dl585 ~]# pvs > kevin.txt

[root at linux-dl585 ~]# cat kevin.txt

No matter what LVM command I run (i.e. vgdisplay, lvs, etc. etc.), it
will not redirect output to my text file. Screen output is always
successful, and every other system command I have tried (i.e. fdisk,
etc.) will redirect output successfully. 

Any ideas?


More information about the linux-lvm mailing list