[linux-lvm] Redirecting LVM command output on RHEL5?

Stuart D. Gathman stuart at bmsi.com
Wed Aug 1 19:59:58 UTC 2007

On Wed, 1 Aug 2007, Joubert, Kevin wrote:

> [root at linux-dl585 ~]# pvs
>   PV         VG   Fmt  Attr PSize  PFree
>   /dev/sda   vg01 lvm2 a-   10.00G    0
>   /dev/sdd   vg02 lvm2 ax    1.95G 1.08G
>   /dev/sde   vg02 lvm2 ax    1.95G 1.46G
> [root at linux-dl585 ~]# pvs > kevin.txt
> [root at linux-dl585 ~]# cat kevin.txt
> No matter what LVM command I run (i.e. vgdisplay, lvs, etc. etc.), it
> will not redirect output to my text file. Screen output is always
> successful, and every other system command I have tried (i.e. fdisk,
> etc.) will redirect output successfully. 

Check your SELinux log.  The GUI should have SELinux Troubleshooter.
You'll find that in addition to forbidding pipes, lvm is also restricted from
updating .cache :-(

I think it is a policy bug.  The troubleshooter will suggest a rule to add.

	      Stuart D. Gathman <stuart at bmsi.com>
    Business Management Systems Inc.  Phone: 703 591-0911 Fax: 703 591-6154
"Confutatis maledictis, flammis acribus addictis" - background song for
a Microsoft sponsored "Where do you want to go from here?" commercial.

More information about the linux-lvm mailing list