[linux-lvm] Help: Mount point does not report full size of LV.

Nick Gyma nickgyma at gmail.com
Wed Feb 28 16:10:32 UTC 2007

Hey all, linux n00b here runing ubuntu:

I added a 3rd hdd to my system today and tried to extend the logical volume
i currently had with the new added space. it was previously a windows NTFS
disk (formatted clean before transfer). after going through the steps it all
displays properly under "vgdisplay -v" but when i actually go and check the
mount point folder size it is still the same as before and has not increased
along w/ the volume group and logical volume.

I've tried to remove the hdd from the VG to try and redo it but i get errors
when trying to use "vgreduce" to remove the PV, saying "physical volume
"dev/hdd1" still in use", even after running a "pvmove" command which
resulted in "no extents avail for allocation".

Here's what I did wrong in setting it up, even though it displays correct:

I first ran fdisk on /dev/hdd1, the partition, instead of the whole disk
/dev/hdd (first mistake). I created a partition, sized it to take the full
space, changed it to 8e, which gave me /dev/hdd1p1. which i really didn't
want, but it happened anyway.

I then did a pvcreate /dev/hdd1, not hdd1p1, then did "vgextend VGforMyth
/dev/hdd1" then did "lvextend --size +79.3G /dev/VGforMyth/video"

Somewhere along the way i realized what i was doing wrong and went back and
fdisk'ed /dev/hdd to remove the two partitions (hdd1, hdd1p1) and create a
new correct partition /dev/hdd1 set to 8e and extending the entire disk.
Now, /dev/hdd1 was still part of the VG while "fixing" the issue. I'm
guessing doing all that screwed it up somewhere along the way.

Is there a way to fix the LV as it is so that the mount point
/home/nick/video is correct? or should i wipe it all out and start over? if
so, how do i go about doing that? do i delete all data on the LV then do a
vgremove then fdisk everything, deleting all partitions and start over?

Thanks in advance for your help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/linux-lvm/attachments/20070228/a793620e/attachment.htm>

More information about the linux-lvm mailing list